Upgrading Kubernetes Components


root@shakeelj1c:~# kubeadm upgrade apply v1.13.1 --force
[preflight] Running pre-flight checks.
[upgrade] Making sure the cluster is healthy:
[upgrade/config] Making sure the configuration is correct:
[upgrade/config] Reading configuration from the cluster...
[upgrade/config] FYI: You can look at this config file with 'kubectl -n kube-system get cm kubeadm-config -oyaml'
[upgrade/apply] Respecting the --cri-socket flag that is set with higher priority than the config file.
[upgrade/version] You have chosen to change the cluster version to "v1.13.1"
[upgrade/versions] Cluster version: v1.12.3
[upgrade/versions] kubeadm version: v1.13.1
[upgrade/prepull] Will prepull images for components [kube-apiserver kube-controller-manager kube-scheduler etcd]
[upgrade/prepull] Prepulling image for component etcd.
[upgrade/prepull] Prepulling image for component kube-apiserver.
[upgrade/prepull] Prepulling image for component kube-controller-manager.
[upgrade/prepull] Prepulling image for component kube-scheduler.
[apiclient] Found 0 Pods for label selector k8s-app=upgrade-prepull-kube-scheduler
[apiclient] Found 0 Pods for label selector k8s-app=upgrade-prepull-etcd
[apiclient] Found 0 Pods for label selector k8s-app=upgrade-prepull-kube-controller-manager
[apiclient] Found 0 Pods for label selector k8s-app=upgrade-prepull-kube-apiserver

I am trying to upgrade but i keep getting stuck at the above error. Can someone help?
  • post-author-pic
    Victor C
    01-08-2019

    Make sure you upgrade kubeadm, kubelet, kubectl to v1.13.1 before upgrading the cluster.

  • post-author-pic
    Shakeel J
    01-09-2019

    I did that,  the  upgrade process was a bit slow, upgrade completed successfully

  • post-author-pic
    Ermin K
    01-09-2019

    Glad you solved it! If did not however please open a ticket and we will jump to it!

Looking For Team Training?

Learn More