Cluster create instruction is now outdated

Hi,

Today I've started the course but had problem with starting the lab cluster as in the instruction. I followed the instructions, and after applying flannel network cni I still had:

kubectl get pods --all-namespaces
NAMESPACE NAME READY STATUS RESTARTS AGE
kube-system coredns-576cbf47c7-sxg9m 0/1 Pending 0 2m35s
kube-system coredns-576cbf47c7-xv22g 0/1 Pending 0 2m35s


kubectl get nodes
NAME STATUS ROLES AGE VERSION
zl0ty4c NotReady master 7m3s v1.12.2


Looks like the course is bit dated now or just lab images 'CloudNative Kubernetes' were updated. But according to 

https://github.com/coreos/flannel


For Kubernetes v1.7+

kubectl apply -f https://raw.githubusercontent.com/coreos/flannel/master/Documentation/kube-flannel.yml

It solved the issue. Now you either have to downgrade or make separate downgraded images for that course, or make a big bold note in the course, so that it saves someones time and frustration ;)

  • post-author-pic
    Will B
    11-12-2018

    Thanks for providing this info! I went ahead and added a note to the description of that video to help students for the time being, until we get a chance to update the video.

  • post-author-pic
    Pat P
    11-14-2018

    Look like also there is other problem. Every time I begin to learn, and my servers were already shutdown, k8s cluster is not able to start. All nodes are in not ready state, kube-system pods related to dns 'coredns-*' arein 'CrashLoopBackOff' status, and in events (kubectl get events) I can see statuses indicating that hostnames of all members are 'linuxacademy'. So I've restarted kubelet on all nodes and that solved the issue - cluster seems to be working, normal pods work, coredns pods are in 'CrashLoop(...)' state, but all seems fine.


    Looks like k8s start before hostnames are assigned and try to refer to generig 'linuxacademy' hostname. When I will have time I will try to modify kubelet systemd unit to apply some timeout to wait for all scripts to setup hosts.

Looking For Team Training?

Learn More