Updating kernel package lab

I got this [root@linuxacademy1 ~]# rpm -ivh kernel-3.10.0-957.el7.x86_64.rpm

error: Failed dependencies:

dracut >= 033-502 is needed by kernel-3.10.0-957.el7.x86_64

selinux-policy-targeted < 3.13.1-201 conflicts with kernel-3.10.0-957.el7.x86_64

xfsprogs < 4.3.0 conflicts with kernel-3.10.0-957.el7.x86_64

kmod < 20-9 conflicts with kernel-3.10.0-957.el7.x86_64

kexec-tools < 2.0.14-3 conflicts with kernel-3.10.0-957.el7.x86_


I did update each one separately, but if this were to happen on the exam which command would be best? It offered yum-complete-transaction as well.

  • post-author-pic
    Rob M
    11-08-2018

    If a package has dependencies, using yum to install it helps a lot since yum will automatically resolve and install them as required.

    So you'd simply "yum install kernel-3.10.0-957.el7.x86_64.rpm" to get the package installed.

  • post-author-pic
    Ermin K
    11-09-2018

    Basically as Rob already stated and as the error message states, you need to install all the packages yourself and satisfy all the dependencies.

  • post-author-pic
    Tariq A
    11-09-2018

    Ermin could you respond to this please.

    https://linuxacademy.com/cp/socialize/index/type/community_post/id/31741

Looking For Team Training?

Learn More