How to paste using Mac within Linux lab terminal sessions

Hi Guys,

Any ideas?  When I press command and V I get (V) coming up.  I have tried a few other ways, Control V etc to paste but no joy..
thanks
  • post-author-pic
    Ryan R
    11-04-2018

    It only able to work when inside the terminal actually copying via control shift + C / V etc.   But doesnt work outside the terminal to copy things.

  • post-author-pic
    Francisco S
    11-05-2018

    I tried on Playground and SSH Terminal and Cmd + V seems to paste properly. Can you try to paste using right-click > paste, or this isn't working for you either?

  • post-author-pic
    Chad C
    11-05-2018

    Hey Ryan, sorry that you're having trouble copying and pasting.  Which lab are you in? What are you copying from?


    I've tried this lab here to Kill or Adjust Process Priorities:

    https://linuxacademy.com/cp/livelabs/view/id/332/module/39


    I was able to successfully copy and paste (command + c and command + v) from textedit to the terminal session.  I was also able to successfully copy and paste from the browser to the terminal to enter the given credentials.

    I have also successfully copy pasta using our new instant terminals and using our original cloud servers.  

    I am running MacOS Mojave version 10.14

    I hope this helps. 

    Also, if you're interested, you can install iterm2 and customize your terminal a lot more.  https://iterm2.com/


  • post-author-pic
    David S
    11-05-2018

    Hi,  @weekendwarrior 


    It sounds like you are working inside a lab environment, which is slightly different for copy / paste than inside our Playground servers and instant terminals.

    I suspect that you will need to use the Shift + Control + Option(Alt) to open up the clipbard side window. Then Shift + Control + Option again to close it. After that, I think standard Control + V should paste the content that you added to the clipboard. 

    We realize this is (more) than a bit of a hassle, and we hope to have a better solution in place.

    I hope this helps!

    ~David

  • post-author-pic
    Sean G
    11-05-2018

    Are you using a learning activity/challenge? If so, the web based terminal for those currently does not support copy/paste. 


    If you're using a cloud server/playground server, then copy/paste should work, but as others have said the keyboard command may be slightly different.

Looking For Team Training?

Learn More