logging option not getting changed

The logging option is not getting changed, here are the daemon.json file and docker info print

[root@eixxxx docker]# cat daemon.json

{

"storage-driver":"devicemapper"

}

{

"log-driver":"syslog",

"log-opts":{

"syslog-address":"udp://172.31.30.68:514"

}

[root@eixxxx docker]# docker info | grep -i logging

WARNING: devicemapper: usage of loopback devices is strongly discouraged for production use.

Use `--storage-opt dm.thinpooldev` to specify a custom block storage device.

Logging Driver: json-file

Any clues?

Regards,AC

  • post-author-pic
    Terrence C
    10-09-2018

    Two things:

    1. Make sure you have restarted the Docker service so it reads the configuration
    2. Make sure you have installed syslog, configured it to listen on the PRIVATE address (assuming you are using our cloud servers, port 514 will not be available) and have started the logging service

    Good luck!

  • post-author-pic
    Anuraag C
    10-10-2018

    Hi Terrence,

    Thanks for the reply, Here is the sequence of steps I followed in our linux academy cloud server:
    1.  edited the daemon.json file and added the eth0 IP address, and port 514 , should I use another port and which one if not 514?
    2. Post creation of daemon.json file, I restarted the docker service
    3. And yes I did edited the rsyslog.conf to uncomment the 2 lines on UDP as you showed in your lecture.
    4. Now, syslog and docker services are up and running
    5. I check the logging option in docker info, and it was not changed.
    Please suggest
    Regards,
    AC

Looking For Team Training?

Learn More