Create Service/Demo Project

I am getting below message while creating service or demo project.
root@controller:~# openstack project create --domain default --description "Service Project" service
The service catalog is empty.
root@controller:~# openstack project create --domain default --description "Demo Project" demo
The service catalog is empty.
root@controller:~# openstack catalog list

root@controller:~#

Was bootstarp command supposed to setup any endpoints?
  • post-author-pic
    Amy M
    09-13-2018

    Keystone endpoints were created earlier in the installation processes. Add —debug to your command, and that is dash dash debug. It will give you the debug output which should help narrow down the error.

  • post-author-pic
    Rajdeep R
    09-14-2018

    Yeah, the bootstrap should have created the endpoints. If I re-run bootstrap commands, I get below message in the log file but endpoints don't show up. I am still looking into it, will share if I get something.

    2018-09-14 11:42:41.273 2790 INFO keystone.cmd.cli [-] Domain default already exists, skipping creation.
    2018-09-14 11:42:41.389 2790 INFO keystone.cmd.cli [req-58527648-5471-40c7-a93a-5f5ce688647f - - - - -] Project admin already exists, skipping creation.
    2018-09-14 11:42:41.459 2790 INFO keystone.cmd.cli [req-58527648-5471-40c7-a93a-5f5ce688647f - - - - -] User admin already exists, skipping creation.
    2018-09-14 11:42:42.113 2790 INFO keystone.cmd.cli [req-58527648-5471-40c7-a93a-5f5ce688647f - - - - -] Role admin exists, skipping creation.
    2018-09-14 11:42:42.675 2790 INFO keystone.cmd.cli [req-58527648-5471-40c7-a93a-5f5ce688647f - - - - -] User admin already has admin on admin.
    2018-09-14 11:42:42.703 2790 INFO keystone.cmd.cli [req-58527648-5471-40c7-a93a-5f5ce688647f - - - - -] Region RegionOne exists, skipping creation.
    2018-09-14 11:42:42.747 2790 INFO keystone.cmd.cli [req-58527648-5471-40c7-a93a-5f5ce688647f - - - - -] Skipping admin endpoint as already created
    2018-09-14 11:42:42.747 2790 INFO keystone.cmd.cli [req-58527648-5471-40c7-a93a-5f5ce688647f - - - - -] Skipping internal endpoint as already created
    2018-09-14 11:42:42.748 2790 INFO keystone.cmd.cli [req-58527648-5471-40c7-a93a-5f5ce688647f - - - - -] Skipping public endpoint as already created


  • post-author-pic
    Rajdeep R
    09-14-2018

    I see below warning in keystone-manage.log, should I be concerned about it?

    2018-09-13 11:57:23.491 6469 WARNING py.warnings [req-1867fd89-4492-4be3-904d-94a6ad89242b - - - - -] /usr/lib/python2.7/dist-packages/pycadf/identifier.py:80: UserWarning: Invalid uuid: RegionOne. To ensure interoperability, identifiers should be a valid uuid.

    'identifiers should be a valid uuid.' % (value)))


  • post-author-pic
    Amy M
    09-14-2018

    The messages of the domain already existing if you re-ran the bootstrap vs rolling back and restarting makes sense. I am however concerned with the uuid RegionOne log entry. Can you look in the logs for the initial run?

  • post-author-pic
    Rajdeep R
    09-30-2018

    After trying to fix this issue for so many days, I finally gave up and installed a new controller node and it is working fine but found that above "UserWarning: Invalid uuid: RegionOne." is showing up in the new node as well so this issue is not related to it for sure. 

  • post-author-pic
    Amy M
    10-01-2018

    Hey just followed up with the Keystone team and basically, the OpenStack CLI tries first with your input as a UUID and then tries again with the input as a name so all is working as expected!

Looking For Team Training?

Learn More