No packages marked for update

Getting the above error while running yum update . I am using centOS7 of linux academy. Please help 
  • post-author-pic
    Keith T
    09-12-2018

    The CentOS image is frequently updated and that message indicates that everything on your cloud server is up-to-date.

  • post-author-pic
    Jake W
    09-12-2018

    To add to what Keith said, yum will first update its cache of known packages with the latest versions available via its repositories. If the version present on the system is older than the version available in a repo, the package is 'marked for update.' The yum update command will then pull down the new versions of any marked packages. So then, after yum checks to see if there are any updates available, and performs the second task of applying any updates, it sees no marked packages and exits with the message you are seeing.

    If you'd like to see a more tangible example of this, I invite you to spin up a Ubuntu server, where you first run 'apt-get update' to update the cache, then 'apt-get upgrade' to pull down any packages marked as requiring an update. With yum, it's one step.


    Hope this helps!

  • post-author-pic
    Kamna S
    09-12-2018

    Thank you. This information is indeed helpful.

Looking For Team Training?

Learn More