Receiving Errors, No package httpd24 available ,No package php70

I am using a windows laptop and keep keep getting the following errors when trying to install PHP and Windows.I am using Putty and have followed the instructions closely, but am still receiving the below errors. I have been trying to trouble shoot this for 3 days. I am beyond frustrated as I can not complete my labs, please help!!!!! I am able to get through the first install, however when I add, " sudo yum install -y httpd24 php70". I receive the below.

No package httpd24 available.

No package php70 available.

  • post-author-pic
    Ermin K
    09-05-2018

    Are you sure that you have the same repositories?

  • post-author-pic
    Michael R
    09-05-2018

    I was able to install using httpd and php commands, but not as directed in lab to use httpd24 and php70, however I am now getting the error  "Redirecting to /bin/systemctl start httpd.service" when using the "sudo service httpd start command".

  • post-author-pic
    Sean G
    09-05-2018

    which server distribution are you using? If your distribution is different than what is shown in the videos the package names will likely be different as well.

  • post-author-pic
    omerraffat
    09-29-2018

    You are using Amazon Linux 2 instead of Amazon Linux 1.

    Amazon has changed the order of linux distributions since when the lecture was recorded. When it was recordede Amz linux 1 use to be the first one;but now its Amz Linux 2 which appears at the top. Look for Amazon linux 1 Or continue installing  HTTPD  and Php7 using following

    ---

    Tutorial: Install a LAMP Web Server on Amazon Linux 2


    >> Install the lamp-mariadb10.2-php7.2 and php7.2 Amazon Linux Extras repositories to get the latest versions of the LAMP MariaDB and PHP packages for Amazon Linux 2.
    [ec2-user ~]$ sudo amazon-linux-extras install -y lamp-mariadb10.2-php7.2 php7.2


    > > Use the yum install command to install multiple software packages and all related dependencies at the same time.
    [ec2-user ~]$ sudo yum install -y httpd mariadb-server


    > > Start the Apache web server.
    [ec2-user ~]$ sudo systemctl start httpd


    >> Use the systemctl command to configure the Apache web server to start at each system boot.
    [ec2-user ~]$ sudo systemctl enable httpd


    >> You can verify that httpd is on by running the following command:
    [ec2-user ~]$ sudo systemctl is-enabled httpd




  • post-author-pic
    Patrick A
    01-12-2019

    The steps work for me. Thanks.

Looking For Team Training?

Learn More